HOME FORUM RULES CONTACT
     
   
   

Go Back   CLASS RACER FORUM > Class Racer Forums > .90 Heads Up Class Racing Tech


Reply
 
Thread Tools Display Modes
Old 05-28-2007, 09:18 PM   #1
SST159
Member
 
Join Date: Jul 2005
Posts: 301
Likes: 4
Liked 18 Times in 12 Posts
Default Oil pressure problems

Anyone out there ever experience oil pressure dropping to about 10 lbs just after the car passes the 330 ft?
I am out of ideas.
Once the pressure drops, I lift and it will recover right away and I can finish the run with 60 lbs pressure.
Oil pressure is 40 lbs hot at idle no problem
After I saw this I pulled the motor, changed the pump and pickup, went back to the track made a pass and the same thing happened.
I added a qt oil, same thing, added another qt. same thing.
7 qt pan and I usually run 6 qts. ( one in the filter)
Changed the guage, same thing happens.
SBC with moroso eliminator pan 8 1/4" sump. using a Melling pump and pickup.
Any ideas out there?

Drew
S/ST 159
__________________
Drew Wonderly
SST 159
SST159 is offline   Reply With Quote
Old 05-29-2007, 03:48 PM   #2
David 7215
Junior Member
 
Join Date: Jan 2004
Location: Pleasanton CA USA
Posts: 7
Likes: 0
Liked 0 Times in 0 Posts
Default

It has to be due to either the pick up becoming uncovered under acceleration or the pick up being to close/far away from the bottom of the pan. Put a straight edge across the bottom of the pick up and measure up to the engine pan rails. Your pick up should be around 3/8" from the bottom of the pan. To close or to high, you will have oil pressure problems.
Also, if you run a high volume pump, you may be pumping all the oil up to the valve covers unless you are running restrictors in the cam galley. Restrictors make the mains and rods priority and also get the oil back to the pan quicker. However, you can only run restrictors with roller or flat tappit cams.
Good luck

David 7215 is offline   Reply With Quote
Old 05-29-2007, 05:37 PM   #3
SST159
Member
 
Join Date: Jul 2005
Posts: 301
Likes: 4
Liked 18 Times in 12 Posts
Default

Dave,
Thanks for the response.
I did check the pickup clearance and it is within the correct range however I learned today that the Melling pickup I am using may not be far enough back in the pan as needed. I am using restrictors and I am using a Melling race pump that is the anitcavitating +10% volume.
My next step is to try a Moroso pump and pickup package that they match to the exact pan I use. The Moroso pickup is a bit different from the Melling.

Drew
S/ST 159
__________________
Drew Wonderly
SST 159
SST159 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Copyright © Class Racer.com. All Rights Reserved. Designated trademarks and brands are the property of their respective owners.