HOME MAGAZINE FORUM RULES SPONSORS CONTACT
     
   
   
Go Back   CLASS RACER FORUM > Class Racer Forums > Stock and Super Stock Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-27-2015, 07:51 PM   #1
Jim Storms
Member
 
Join Date: Aug 2005
Location: Renton, Washington
Posts: 320
Likes: 0
Liked 4 Times in 2 Posts
Default MSD 7 AL 2 plus ???

Our stocker has a bug,?? Test the car it ran 10.80 @ 122 1.40 60' ran good, next pass car acts super lazy, car runs 11.50 @ 114 1..50 60'.
Battery checks good! Swapped coils, swapped carbs, timing is good, compression is good,
Has anyone had any issues with the 7 AL 2 plus, car don't miss fire at all, checked all I can check besides starting to replace parts, any thoughts are appreciated at this point. MIght add I replaces Trans an coverter as well but problem still exists, an unfortunately this car don't have a data recorder.

Last edited by Jim Storms; 05-27-2015 at 07:54 PM.
Jim Storms is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright © Class Racer.com. All Rights Reserved. Designated trademarks and brands are the property of their respective owners.Ad Management plugin by RedTyger