CLASS RACER FORUM

CLASS RACER FORUM (https://www.classracer.com/classforum/index.php)
-   Stock and Super Stock Tech (https://www.classracer.com/classforum/forumdisplay.php?f=4)
-   -   MSD 7 AL 2 plus ??? (https://www.classracer.com/classforum/showthread.php?t=58170)

Jim Storms 05-27-2015 07:51 PM

MSD 7 AL 2 plus ???
 
Our stocker has a bug,?? Test the car it ran 10.80 @ 122 1.40 60' ran good, next pass car acts super lazy, car runs 11.50 @ 114 1..50 60'.
Battery checks good! Swapped coils, swapped carbs, timing is good, compression is good,
Has anyone had any issues with the 7 AL 2 plus, car don't miss fire at all, checked all I can check besides starting to replace parts, any thoughts are appreciated at this point. MIght add I replaces Trans an coverter as well but problem still exists, an unfortunately this car don't have a data recorder.

Danny Ashley 05-27-2015 08:28 PM

Re: MSD 7 AL 2 plus ???
 
If you are running an MSD distributor it could be the magnetic pick-up. They are notorious for causing lost E.T. and the car doesn't miss a beat.

Jim Storms 05-27-2015 08:37 PM

Re: MSD 7 AL 2 plus ???
 
Thanks. I'll switch that as well., thank you

lareagle 05-28-2015 03:15 PM

Re: MSD 7 AL 2 plus ???
 
Hello Jim
Had similar problem ,the box need rebuilt.
Sent it to Pat Collins phone 704 995 4286 Mid West Tech.
Car pick up .60. Cost $150. Plus he suggest different coil $100.
Cheap fix for all the trips to race track trying to fix.
Good Luck
Larry

Jim Storms 05-28-2015 03:28 PM

Re: MSD 7 AL 2 plus ???
 
Ya I'm close to agreement on the box, it's definitely a key source right now. Thanks for the imput.

Bobby Fazio 05-28-2015 09:51 PM

Re: MSD 7 AL 2 plus ???
 
If that box has the little black timing chips in it, make sure they are all working. We damn near tore apart our whole car at Cecil a few years back and it was a zero timing chip that had lost continuity.

peter dodge 06-07-2015 05:18 PM

Re: MSD 7 AL 2 plus ???
 
Jim, I have the same problem and have done the same things. I just ordered a trigger to try but it checked the same as the old one.I wonder if you have found a solution???, thanks, Pete

Jim Storms 06-09-2015 05:53 PM

Re: MSD 7 AL 2 plus ???
 
Peter, yes the problem was the MSD box , installed new box, back to wheels up , all is good.

peter dodge 06-13-2015 09:11 PM

Re: MSD 7 AL 2 plus ???
 
Jim, In my search I took out a pretty new 7AL3 and put in a new 7AL2, no good! soooo I hope the pickup will help,,,thanks, Pete


All times are GMT -5. The time now is 11:31 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright Class Racer.com. All Rights Reserved. Designated trademarks and brands are the property of their respective owners.Ad Management plugin by RedTyger